The WordPress open-source content management system, CMS, will indicate warning in its backend admin panel whenever the site is being run on an out-of-date PHP version.

The plan in place is to make the warnings display for sites making use of a PHP version preceding the 5.6.x branch (<=5.6).

There will be an inclusion of a link within the warnings; the link will lead to a WordPress support page containing information that sites owners can follow to update the PHP version in their servers.

WordPress PHP Warning

However, if the owners of the sites are using tightly-controlled web hosting environments to run their WordPress portals, then the web host will be presented with the opportunity of altering this link with a custom URL leading to its own support site.

The warning will ship and appear with WordPress 5.1 that is going to be released later in this spring.

The decision to display this warning was reached after the release of WordPress 5.0 branch in December 2018. It was revealed that a large percentage of WordPress 5.0 users, about 85%, were using PHP versions of 5.6 and later to run their sites; this result was derived from an upgrade statistics gathered days after the WP 5.0 was released. As such, only a minute group of active WordPress community will notice these warnings in the first place.

We emphasized “active WordPress community” since many sites are still running old WordPress versions, but the majority of them are either abandoned or forgotten.

The set plan, though short-term, is targeted at migrating a large number of active users to current versions of PHP thereby encouraging WordPress team to stop the use of older PHP versions.

The WordPress team is looking forward to officially make a modification to the WordPress CMS minimum PHP version requirement from the current PHP 5.2 to PHP 5.6 by April 2019. MySQL is also going to have some changes made on it as a minimum requirement version is also planned to have MySQL 5.5 as the new minimum requirement.

There is also a long-term plan to make PHP 7.0 the minimum PHP version required to run a WordPress site by December 2019.

The WordPress community was shocked to hear the announcement made by the WordPress team yesterday as there has not been a modification of the minimum PHP version needed to run a WordPress site for many years.

The reason behind the decision made by the WordPress team to encourage site owners to update their underlying PHP servers is that the PHP team recently stopped supporting security fixes for the PHP 5.6.x and PHP 7.0.x branches. As a result, these older versions can easily be attacked and exploited as revealed by many security researchers.

W3Techs revealed that about 66.7% of all sites on the internet run unsupported PHP versions. It was also revealed that some of the internet sites are run on WordPress, about a quarter of them. The first major CMS project to make known its intention of having users migrated towards currently-supported PHP versions is the WordPress team, great work guys. This change is making the Internet a more secure place.

“The threshold for the PHP notice will increase granularly, with the goal to over time catch up with the actual PHP version progress,” said Felix Arntz, a member of the WordPress open-source CMS team.

Leave a Reply

Your email address will not be published. Required fields are marked *